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If you haven't already installed PhotoToWeb, see the Installation section.

To get an idea of what PhotoToWeb can do:

1. Choose File -> Sample Album.
2. Choose Web -> Create Web Pages... and select a location for the generated
HTML documents.
3. When your web browser opens, browse through the new site.

Quick Start - Intro
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Quick Start - From Scratch

1. Create a new album.
Choose File -> New.

2. Bring in some images.
The easiest way is to drag in a
folder of images from the Finder.
You can also drag in one or more
individual images.

3. Delete images you don't
want.

Click on the name of any image
to view it. Click the Delete button
to remove an image from the
Album but not your hard disk.
Choose File -> Delete Photo to
delete the image file from your
hard disk permanently.
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Quick Start - From Scratch (page 2)

4. Rename your images.

Double-click on an image name in the
image list to edit the name. This
changes the name of the file on your
disk as well as in your album.

5. Rearrange your images.

Click and drag on the dark gray
knob next to the image name to
reorder the images. This sets the
order of the images on the web site.
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Quick Start - From Scratch (page 3)

6. Rotate, size, and crop your images.

Click the Display Options Drawer button to show
additional information about the selected image.

To rotate an image, use the radio buttons. To rotate all images in the album, use
Web -> Web Rotation….

To set the output size for the individual image, use the slider or enter a value into the
text field. To set the output size for all images in the album, use Web -> Web
Scale…. When you change the image size, you can check the estimated size of the
output file.

To crop an image, click and drag anywhere in the
image. The rectangle shows the area that will be
displayed when the web pages are generated.
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7. Annotate your images.

Each  image can have a title (the default is the image file name), a caption, and a
story. Select the image in the image list and type in the text you want to appear with
the image. Be sure to press the Return key after editing the Title and Caption fields.
The story can be full rich text (RTF), with multiple fonts, colors, and typestyles. You
can also drag and drop RTF files into the story text area.

Quick Start - From Scratch (page 4)

To see what your scaled, rotated,
and cropped images will look like
(and also get an estimate of
download speed) choose Views ->
Preview Web Image.
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8. Choose the look of your web pages.

Choose Web -> Web Options… to set the background color, add a
background image, set the text and link colors, add a navigation bar, even
add your own HTML. See the Web Options section for a complete
description.

9. Generate the web pages.

Choose Web -> Create Web Pages…. See Creating Web Pages for a
description of the available options. You'll be asked to name the directory
for the pages. After PhotoToWeb creates the web pages, your web browser
will be notified to open the new pages automatically. 

10. Put the web pages on the web.

Once PhotoToWeb creates the HTML and image files, you’ll need to
transfer the files to a web server to make them publicly available. The
easiest way to do this is to use your iDisk account. In Mac OS X, you can
mount your iDisk (in the Finder, choose Go -> iDisk) and then just drag and
drop the folder created by PhotoToWeb to the Sites folder on your iDisk. To
put your folder on another server, you’ll probably need to use an ftp
application.

Quick Start - From Scratch (page 5)
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Preparing Your Images

In PhotoToWeb, you work with your images in an album, where you can change
their size, crop them, rename them, and annotate them. If you want to modify
your images in other ways (for example, change the contrast or sharpen the
image), you'll need to do that in a separate image manipulation program.

Creating a New Album

To create a new album, choose File -> New.

To create a new album from a previously-saved album style, choose File ->
New From Styles… and choose a style.

Opening a Previously Saved Album

To open an album that you have already created and saved, you can:
• Double-click on that album in the Finder
• Drag the album from the Finder to the PhotoToWeb option in the dock
• Choose File -> Open… and select the album in the Open File dialog

A Note about Albums: PhotoToWeb’s albums store images as
pathnames to the image file (e.g.
“/Users/Documents/OlympusPhotos/December2001/P100032.jpg”). If you
move your images after you create an album (and the album is not stored
in the same folder as the images), or if you rename the images in the
Finder or in another album, the pathnames will change and the album will
not be able to locate and display the images (at least, not without your
help). See Technical Info: Albums for more information.
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Adding Images

To add images to an album, you can:

• Drag a folder containing image files and drop it anywhere in the Album window.

• Drag in an individual image file or group of image files.

• Choose File -> Open Photos… and use the Open File dialog to select a folder
or image file.

You can add images in the following file formats:

JPEG, GIF, TIFF, PDF, PNG, BMP, PICT, ICO, ICNS, and even others.

Preparing Your Images - Adding
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Preparing Your Images - Viewing

To work with an individual image, you need to select it.

To select an image, you can:
• Click on an image name in the image list
• Use the arrow buttons below the image list to move up
and down through the list

The selected image will show in the PhotoToWeb
viewing area. The size of the image in the viewing
area, as a percentage of the image’s original size, is
displayed in the lower right hand corner of the
viewing area.

To change the size of the image in the viewing
area, resize the window. This does not change the
output image size (see Setting Image Size).

To see how the image will appear on the web, given your current settings,
choose Views -> Preview Web Image.

The images you’ve added to your
album show up in the image list.
The number of images in the
album is displayed in the upper left
hand corner of the image list.
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Preparing Your Images - Deleting

To delete an image from the album
only (the image file will remain on
the hard disk), click on the Delete
button at the bottom of the image list.

To delete an image file from the hard disk (permanently removing
it), chose File -> Delete Photo. You will be asked to confirm your
decision to permanently delete the image file.
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Preparing Your Images - Renaming

You can rename the image files on your hard disk using PhotoToWeb. This is
particularly useful when you've imported a folder-full of photo images from a
digital camera with cryptic names like P0000484.jpg. With PhotoToWeb, you
can see the image while you're renaming it so you can give it a descriptive
name.

To rename an image file, double click on the image name in the image list
and type in the new name. When you press the return key or the tab key, the
image filename will be changed and the next image name will be selected,
ready for editing.

Don’t worry about the file extension; PhotoToWeb will add the original file
extension on to the image name if it’s not already there.

Note: PhotoToWeb uses the image file name as the default title (see
Annotating Images), after replacing underscores with spaces and
eliminating the file extension. For example, the image
“Treetop_Ornament.JPG” will, by default, have the title “Treetop Ornament”.
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Preparing Your Images - Reordering

You can set the order in which your images appear on your website by
changing the order of the images in the image list.

To reorder images, you can:

• Click on the dark grey button beside
the image name in the image list and
drag the image to where you would
like it to be.

• Click on a thumbnail in the
Thumbnails view (Views ->
Thumbnails or Shift-Command-
T) and drag the image to where
you would like it to be. The
Thumbnail view gives you a
preview of all the images in the
album.

Note: If there are a lot of images
in the album, it might take
PhotoToWeb a few moments to
generate the thumbnails.
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Preparing Your Images - Sizing

You can set the size of each image, either individually or for all images currently in
your album. This size has no impact on your original file; it only affects the images
PhotoToWeb generates for the web output.

The size controls for individual images are in the Options Drawer of the main album
window. To show the Options Drawer, click on the round button in the lower left
corner of the album’s window.

• Enter a percentage in the text field and press Return.

• Drag the slider until you reach the desired size. As you drag the slider, the
Width, Height, Percentage and Estimated Size information will change.

• Click on the arrows to the left or right of the slider. Clicking on the arrow on the
left will decrease the scale percentage by 5%. Clicking on the arrow on the right
will increase the scale percentage by 5%.

To set the output size for an individual image, you can:
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Preparing Your Images - Sizing (page 2)

You can also preview and size your image in Views -> Preview Web Image.

In this window, you can see the direct relationship between image size, image
quality (see Setting Image Quality) and download time.

To set the individual image size here, click and drag on the size slider.

Note: The Size slider setting affects only the image being viewed. The Quality
slider affects all the images in the album. 
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Preparing Your Images - Sizing (page 3)

To change the size of all images in an album:

Choose Web -> Web Scale… (Shift-Command-X) and use the slider, text
field, or arrows.

To scale all photos to an absolute width,  choose the Absolute Width radio
button and enter a width in pixels.
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Preparing Your Images - Sizing (page 4)

To set the default scale
percentage for newly-
created albums and for
images added to the current
album, choose PhotoToWeb
-> Preferences… ->
Layout, and use the text
field, slider, or arrows.
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Preparing Your Images - Rotating

To set the rotation for an
individual image, click one of
the Rotation radio buttons in the
Options Drawer:

To set the rotation for all the
images in the current album,
choose  Web -> Web
Rotation... and click one of the
radio buttons.
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Preparing Your Images - Copyright

PhotoToWeb lets you superimpose a line of copyright information over your
photos.

To add copyright information to your photo, choose Web -> Copyright… to
bring up the Copyright Information window and type in the text you want to appear.
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Preparing Your Images - Copyright (page 2)

To change the font, select the text and click the Fonts… button to bring up the
Font dialog.

To change the text’s color, select the text and click the Colors… button to bring
up the standard Colors dialog.

To set the location of the line of text, use the Location radio buttons.

To apply the copyright information, click the OK button.

To preview your images with the copyright information, choose Views ->
Preview Web Image.
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To apply the copyright information as currently specified to all future albums,
click the Set for All New Docs button. Of course, these settings are can be
overridden in a particular album.

The copyright information is also stored in Album Styles.

Preparing Your Images - Copyright (page 3)
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Preparing Your Images - Cropping

Sometimes an image will include more than you really want to display. With
PhotoToWeb, you can crop the image to display only what you want.

To crop an image, click and drag in the image itself. A rectangle will appear.
When you've selected what you want to appear, release the mouse button. The
rectangle encloses the section of the picture that will appear when the HTML is
generated.

To remove the cropping rectangle, click anywhere in the
image.

To resize the cropping rectangle, drag it by any edge. The
cursor will change to show that it will resize the rectangle.
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Preparing Your Images - Cropping (page 2)

To view your cropped image, choose Views -> Preview Web Image
(Shift-Command-I). This window displays the cropped and scaled image.

You can also see the cropped image in the Thumbnails view (Views ->
Thumbnails (Shift-Command-T)).

If you want to save your cropped image as a file or use it in another
application that accepts drag and drop images, use the Image Well.
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Preparing Your Images - Image Well

With the Image Well, you can
drag the image, in its current
transformed state, to other
applications, to a folder, or even
into PhotoToWeb itself. This
makes PhotoToWeb an excellent
application for cropping, scaling,
and rotating bitmap images
needed in other applications.

To use the image well, select an image, apply scale, rotation, and cropping as
desired, and click and drag in the image well. You can drag to:

• A folder or the desktop: a new JPEG file will be created.

• Another application that accepts image drag and drop.

• The current PhotoToWeb album. This is useful if you'd like to show both the
original image and a cropped area of the image in your website.

• Another PhotoToWeb album. This is an easy way to copy images to another
album.

Note: If the image has not been transformed at all (the scale is set to 100% and
there's no cropping), the Image Well will create a link rather than a new file.
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Preparing Your Images - Annotating

Each image can have a Title, a Caption, and a Story. To enter this
information, use the text fields in the Option Drawer of the main album window.

Title

Caption

Story
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The Title defaults to the image filename without the filetype extension and with
spaces substituted for underscores. You can choose whether the Title appears at
all or appears above or below the image on the web pages and in the Table of
Contents. See Web Options for more details. The Title is also used to set the title
of the HTML page. To change the default Title, edit the Title text field.

The Caption appears in italics centered immediately below the image. To enter a
caption, type in the Caption text field. If you don't want a caption. leave the
Caption field empty.

The Story appears below the image and caption. You can format the story as full
rich text, including different fonts, font sizes, font styles and colors. You can also
add hypertext links to words or phrases within the story.

To enter a story, you can:

• Type text into the Story text field. Use the Format menu and the Font window to
choose fonts, styles, sizes, and colors.

• Drag and drop an RTF file onto the Story text field.

Story Length: Stories can be as long as you want. The width of the story on the
web page is set by the width of the image.

Font Usage: Fonts that can appear in a viewer’s browser are limited to the fonts
actually installed on that viewer’s computer. So if you use an unusual font in your
story, the viewer may only see Arial or Helvetica.

Preparing Your Images - Annotating (page 2)
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Preparing Your Images - Adding Links to Stories

To add a hypertext link (URL) to text in the story:

1. Select the text that you want linked in the story.

Either:

2a. Drag a URL from a web browser or bookmark window onto the selected text:

2b. Choose Web
-> Story Links
Inspector….
Type in the URL
and press the
Return key or
click on the OK
button.
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Preparing Your Images - Adding Links to Stories (page 2)

After you’ve added a link, the selected text will be underlined. When the HTML for
the web page is generated, that text will act as a link to the specified URL.

To open a link in your browser, select the linked text, choose Web -> Story
Links Inspector… and click on the Open Link button. The linked page will be
opened in your default web browser.
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Preparing Your Images - Deleting Links

To remove a link, select the underlined text or click anywhere within the
underlined text without selecting any text. Then choose Web -> Story
Links Inspector… and click on the Delete Link button.

To remove text from the beginning or end of the link, select the text
that you don't want to be part of the link. Choose Web -> Story Links
Inspector… and click on the Delete Link button. If you select text in the
middle of the link, the link will be removed from that text through the end
of the link.

If you add text within the linked text or add text to the end of the linked
text, that text will also be linked. Text added immediately before the linked
text will not be linked; you’ll need to manually add the link to that text if
you want it to be part of the linked text.
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Web Options

To set how your web pages will look in the current album, choose Web -> Web
Options… and use the controls there.

To set the default web page appearance (the initial web options settings for new
albums), choose PhotoToWeb -> Preferences….

To save web option settings for use with future albums, see Album Styles.

PhotoToWeb
gives you
control over
your web page
appearance.
These two
pages  were
made by simply
changing the
web options.



31PhotoToWeb Manual

Web Options

Table of Contents
Navigation Bars
Image Title
Picture Frame
Other
Colors
Background Image
Extra HTML
Keywords
Misc
Home Page URL
Page Title
Image Quality

Quick Start
Image Prep
Web Options
Album Styles
Preferences
Web Output
Library Trees
Slide Shows
Installation
Technical

2
8

30
51
55
62
66
72
74
77

Web Options - Layout - Table of Contents

The Table of Contents page provides
a link to each image page in your
album. 

To set the appearance of the Table
of Contents page, choose Web ->
Web Options… and go to the
Layout tab.

To choose to have no table of
contents page, click the None radio
button.

To choose to have a text only table
of contents page, click the Text only
radio button. The images’ Titles are
used for the text links.

Note: the text color of the table of
contents is set by the link color
setting (Web -> Web
Options…:Colors).

To choose to use thumbnail images
in your table of contents, click the
Thumbnails radio button.
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Web Options - Layout - Table of Contents (page 2)

To set the size of your
thumbnails, enter a pixel
value in the Size text field.
This value will set the
longest dimension of the
thumbnail: for a horizontal
image, the longest
dimension is the width.
For a vertical image, the
longest dimension is the
height.

To set the arrangement
of your thumbnails,
enter values for the
number of thumbnails per
row and the number of
rows per page. By varying
these numbers, you can
change the look of your
table of contents.

To set the location of the image title or even whether the image title
appears at all, use the Title radio buttons. This setting affects both the
thumbnails and the individual pages.
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The title of the table of contents page is based on the Page Title Prefix setting in
the Misc tab of the Web Options window. The title consists of the text in the Page
Title Prefix text field followed by “Table of Contents”.

To change the title of the table of contents page, enter a new value into the Page
Title Prefix text field.

Note: The Page Title Prefix is also used for the titles of the individual pages in your
album.

The table of contents thumbnail images can
have a colored frame.

To set the size and color of the frame, use
the color well and slider. This also sets the size
and color of the frames on the individual image
pages. The border size for thumbnails is 1/2 the
width of the image border size.

Web Options - Layout - Table of Contents (page 3)
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Web Options - Layout - Navigation Bars

Navigation bars allow the user to progress sequentially through the images. The
navigation bar allows users to go to the next image, the previous image, the table
of contents, or the "Home" page. (To see how to specify the Home page, see the
Misc tab.)

To set the location of the navigation bar, check the Above and/or Below
checkboxes. You can have a navigation bar at the top of the page, the
bottom of the page, or in both places.

To choose to have no navigation bar, uncheck both the Above and Below
checkboxes.

To use a text navigation bar, make sure the Use graphical nav bars
checkbox is unchecked.
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Web Options - Layout - Navigation Bars (page 2)

To use a graphical
navigation bar, check the
Use graphical nav bars
checkbox and select a
graphical style from the
menu. See the choices to
the right.

To add a horizontal line
between the navigation
bars and the content,
check the line between
content and bars
checkbox.
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Web Options - Layout - Custom Navigation Bar

To use a custom graphic navigation bar
instead of one of PhotoToWeb’s navigation bars:

1. Choose Custom… from the graphical
navigation bar menu.

2. Drag and drop your custom images from the
Finder or any graphic program that supports
drag and drop into the appropriate image well in
the custom image window.

3. Click the OK button.
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Web Options - Layout - Custom Navigation Bar (page 2)

When PhotoToWeb
generates the navigation
bar HTML, it will use your
custom images.

Hint: To make custom
contiguous navigation bar
images, you can use
Create® to make the whole
image and then divide it in
SliceAndDice™. You can
then drag the SliceAndDice
generated images into the
image wells in
PhotoToWeb.

To save your custom navigation bars for use in other PhotoToWeb albums, add
an album containing the custom navigation bar to Album Styles. Then when you
create new albums using that Album Style, those albums will use the custom
navigation bars.

Note: Custom navigation bar images are stored as absolute paths in the album file. If
you move or rename those images, PhotoToWeb will be unable to use them.



38 PhotoToWeb Manual

Web Options

Table of Contents
Navigation Bars
Image Title
Picture Frame
Other
Colors
Background Image
Extra HTML
Keywords
Misc
Home Page URL
Page Title
Image Quality

Quick Start
Image Prep
Web Options
Album Styles
Preferences
Web Output
Library Trees
Slide Shows
Installation
Technical

2
8

30
51
55
62
66
72
74
77

Web Options - Layout - Image Title

You can select whether you want the the image’s title
to appear above the image, below the image and
caption but above the story, or not appear at all. 

To set the title location, use the Title radio buttons on
the Layout tab of the Web Options window.

To set the title, enter text into the Title text field in the
Options Drawer of the main window.

Note: The title setting also sets where the image titles
appear in the thumbnail table of contents.

Title

The Opening Act

Dancing, drumming, juggling and stiltwalking open the big BIG Show!

Welcome to PhotoToWeb, which lets you review images
, rename them, reorder them, remove bad ones, annotate them 

and instantly build a web site! Choose 

 (such as 
from digital cameras)

Photos->Create Web Pages... 

Created with  at 2001-12-06 10:54:01 -0700Stone Design's PhotoToWeb®

Dancing, drumming, juggling and stiltwalking open the big BIG Show!

The Opening Act

Welcome to PhotoToWeb, which lets you review images
, rename them, reorder them, remove bad ones, annotate them 

and instantly build a web site! Choose 

 (such as 
from digital cameras)

Photos->Create Web Pages... 

Created with  at 2001-12-06 10:52:00 -0700Stone Design's PhotoToWeb®
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Web Options - Layout - Picture Frame

Images can be surrounded by a border
(picture frame).

To set the picture frame size and color, use
the Picture Frame controls on the Layout tab
of the Web Options window. Each tick mark
represents a single pixel.

For no picture frame, drag the size slider all
the way to the left.

Note: this setting also affects the picture
frame size and color for the thumbnails on the
Table of Contents page. The size for
thumbnails is set to 1/2 the size of the picture
frame for the images themselves. 
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Web Options - Layout - Other

To include your original images in your website, check the Include fullscale
photos checkbox. When checked, the original full-sized images are converted to
JPEGs if  necessary and copied to the images folder. A link is added from each
photo displayed on the individual image page to that original image.

Use this when you want to provide smaller images for quick web viewing, but also
want to provide the high quality original images to web viewers who have the
bandwidth or patience to download the original image.

To make the font size used in the HTML output slightly larger than that
specified in the Story, check the Use bigger fonts checkbox.
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Web Options - Colors

To set the background and text
colors, use the Color tab in the Web
Options panel. Set each item’s color by
clicking on the appropriate Color Well
and then using the Color dialog to select
the color you want. The colors are
displayed in the field above the color
wells so you can see how your choices
look together.

Tip: you can just click on a phrase in the
preview area to activate its color well.

The Text color choice affects the Title,
Caption, and any text in the Story that
doesn’t already have a color.

The Link color choices affect text menus, text-based Table of Contents items, and
any linked text in the Story.

The scrolling text field at the bottom of the window shows the HTML that will be
generated for the web pages. You can create your own <BODY> tag by typing it
directly into this field, but you can’t combine hand-editing with using the color
panels. If you want additional HTML within the body, see the next section.
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Web Options - Colors - Background Image

To set a background image for your pages, click on the Set button to bring up an
Open File dialog and select the image you want to use as the background. Images
that are smaller than the whole page will be tiled to fill the page.

Hint: You can use Create® to make narrow horizontal or vertical rectangles with
a blend fill (be sure to turn off any border). Save the graphic as a JPEG and use
it as a background image.



43PhotoToWeb Manual

Web Options

Table of Contents
Navigation Bars
Image Title
Picture Frame
Other
Colors
Background Image
Extra HTML
Keywords
Misc
Home Page URL
Page Title
Image Quality

Quick Start
Image Prep
Web Options
Album Styles
Preferences
Web Output
Library Trees
Slide Shows
Installation
Technical

2
8

30
51
55
62
66
72
74
77

Web Options - Extra HTML

You can incorporate
JavaScript,
WebObjects code,
and any arbitrary
HTML on your
PhotoToWeb web
pages. Use the HTML
tab of the Web
Options window to
insert HTML in three
places:

<HEAD> - this is
where JavaScript
routines, meta tags
and Cascading Style
Sheet (CSS) styles
go.

Note: See the Technical Information section for additional information on using
CSS with PhotoToWeb.

You don't have to specify Keywords and Description meta tags here; you can do
that in the Keywords tab.
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Web Output Options - Extra HTML (page 2)

Before content - after the <BODY> tag, but before any image or annotation.

After content - after any image and annotations, but before the “Created with Stone
Design’s PhotoToWeb”  and the final </BODY></HTML> tags.

You are responsible for correct hand written HTML, so type or paste carefully! Also,
if you reference any files, make sure you add them to the directories generated by
PhotoToWeb.
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Web Options - Keywords and Description

To insert Keywords
and Description
metatags into your
PhotoToWeb-generated
HTML, use the
Keywords tab of the
Web Options window. 

Keywords should be a
comma delimited list,
such as the one shown
to the right. Keywords
provide indexing
information for search
engines.

The Description can be
any phrase, but don't
include any quotes!
Many search engines
use the Description as
the abstract (the short
blurb that runs below the
web page title) in the
search results.
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Web Options - Misc

To select full color or
gray scale output,
use the Output images
radio buttons in the
Misc tab of the Web
Options window.

You can use gray scale
to give a very hip a la
“Ciné Noir” look to your
images.

This feature may not
work; it depends on
underlying Mac OS X
features that, as of this
writing, have not yet
been fully
implemented.
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To set the link on the Home button in
the navigation bars generated by
PhotoToWeb, enter a value in the Home
Page URL text field on the Misc tab of
the Web Options window.

To specify a home page in the next
folder up, enter “../whatever the page’s
filename is”. 

To specify a  home page at another
site, enter a full URL specification, such
as “http://www.stone.com/”.

By default, the home page link is set to
index (.html is added automatically to
names which don't end in a "/"). Also by
default, an index page is created in the
directory PhotoToWeb creates; this page
is a symbolic link to the table of contents
page (TOC.html). To change this, see
Preferences.

Web Options - Misc - Home Page URL
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Web Options - Misc - Page Title Prefix

What you enter here is added before the regular page title. It’s seen in two places:

The window title in the viewer’s browser prefixed to the image’s Title:

The title on the Table of Contents page:
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Web Options - Misc - Image Quality

To set the image quality (which impacts the file size) of the output image, use the
Photo slider or enter a value in the text field and press the Return key. The higher
the quality, the larger the size of the image file. By default, the quality factor is .75 or
75%, which gives a nice tradeoff between image quality and image size.

Use the Thumbnail slider to set the image quality of the thumbnail images.

To visually preview your images while setting the image quality, use Views ->
Preview Web Image.
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Web Options - Reusing

PhotoToWeb provides two ways to apply your web output options to future albums.

1. Duplicate the settings in Preferences. The initial web output settings for all
albums created with File->New are based on the Preference settings.

2. Save the album containing the settings you want to reuse and then add that album
to your Album Styles. Album styles can be used to make new albums and can be
applied to existing albums.
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Album Styles
Once you’ve made a particular look for your album by setting the Web Output
options, you can save that look for use in future albums.

Information that is saved with an album style:

• Whether or not to include fullscale photos
• Whether or not to use bigger fonts
• Navigation bar location and style
• Custom navigation bar information
• Picture frame color and size
• Table of contents settings
• Whether or not to display a title and the title’s location
• All of the color information
• Whether or not to use a background image and the image file’s location
• All custom HTML
• The Keyword and Description information
• Image output color information
• Home Page URL
• Page Title Prefix
• Photo and Thumbnail output quality
• Copyright information
• Slide show settings
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Album Styles - Saving Styles

To save a collection of web output settings (an album style) for use in new
albums:

1. Save the album that contains the settings you want to reuse.

2. Open the Album Styles window (File -> New from Styles…).

3. Click the Add… button. In the Open File dialog, find the album whose settings you
want to reuse and open it.

The album will
be added to
the Album
Styles window
with a generic
icon.
You can also
drag an album
file icon from
the Finder to
the Album
Styles window.
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Album Styles - Saving Styles (page 2)

Each album style can have a name, a description and a custom icon.

To change the name and description, edit the Name and Description text fields.

To add a custom icon, drag an image file from the Finder or an application that
supports drag and drop to the icon image well in the Album Styles window.

Hint: Here’s an easy way to get an icon representing an album style: Display a page
from your album in your browser. Choose File -> Print and then choose to print to a
file. In IE, you can choose to print the background as well as the contents. Drag the
resulting PDF file into the image well in the Album Styles window. The image will be
scaled to fit the album style tile.

To delete a saved album style from
the Album Styles window, select the
album style by clicking on its tile, and
click the Remove… button. You will
be warned that this operation cannot
be undone and asked to confirm the
deletion.
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Album Styles - Saving Styles (page 3)

To make a new album using an album style:

1. Open the Album Styles window (File -> New From Styles…).
2. Select the album style you want to use by clicking on its tile.
3. Click the Album from Style button.

An empty Album window will appear with its web options set to the options in the
album style.

To apply an album style to an open
album or library tree:

1. Open the Album Styles window (File ->
New From Styles…).
2. Select the album style you want to use
by clicking on its tile.
3. Drag the album style’s icon from the
icon well to the album or library trees
window.
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Preferences
When you create a new album, the initial web output options are based on the
settings in Preferences. If you have a standard look that you want in all your
albums, make the settings in Preferences. You can, of course, change the settings
for individual albums in Web Options.

Preferences also includes some additional settings that are only available in the
Preferences window. This section discusses those extra settings; please refer to
Web Options for a discussion of the settings that can be made in both panels.

You can always restore all your preferences to the original default settings by
clicking the Factory Settings button.

Changing preferences that duplicate the settings that can be made in an individual
album’s Web Output settings does not affect current albums; it only affects albums
that are created after you click the OK button in the Preferences window. However,
changing the preferences that are described in this section does affect all HTML
output that is generated after the changes are made, including the HTML for
already-created albums.
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Preferences - Options

To keep TIFF
files as TIFFs
(rather than
converting
them to JPEG
files), check
the Preserve
TIFFs in web
checkbox.

To make your
HTML output
slightly
smaller and
much less
readable,
check the
Compact
output
checkbox.
This results in
HTML without
any linefeeds
or extra spaces. Don’t do this unless you’re sure you won’t need to inspect the
code at all. This setting affects any HTML generated after changing the
preference and clicking OK.
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To eliminate the PhotoToWeb credit at the bottom of each page, check the No logo
checkbox. Otherwise, PhotoToWeb puts a line like this at the bottom of each page:

Preferences - Options - No Logo

Changing this setting affects all HTML generated after the Preference is changed
and you click the OK button
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Preferences - Options - Directory Structure

To put all HTML files and images at the top level of the folder created for an
album, choose “All in one directory”. PhotoToWeb will not create an image
subfolder for the album.

When creating  an entire set of linked albums by using the Library Tree, you might
add a hierarchy of folders where some folders contain no images. Normally,
PhotoToWeb will create a folder for each level, but if you want to “condense the
tree structure” by excluding empty folder nodes, check “condense  Albums Tree if
possible.”

For example, if you drag in a folder containing a single album and some images:

If Condense Albums Tree is checked, PhotoToWeb will create an entry for the
album and the folder will not appear.

If Condense Albums Tree is not checked, PhotoToWeb will create a node for the
folder and a subentry for the album.
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Preferences - Misc

To set the units used in the Scale
controls, select a unit here. Your
choices are inches, centimeters,
points, and picas. This control
affects all albums, including albums
that are already open (you may have
to force a redraw by selecting
another image to make the new
units to show up in the Options
Drawer.

To optimize the encoding of your
HTML files to fit your native language,
choose an encoding here. We strongly
recommend that you choose Standard
unless you fully understand the
ramifications of non-standard
encodings! 
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Preferences - Misc - index.html Creation

If a URL does not contain a file name, web servers look for a file named “index.html”.
Given a URL like “http://www.stone.com/Photos/”, browsers will actually display
“www.stone.com/Photos/index.html”. In general, every folder should have an
index.html file.

By default, PhotoToWeb will create an index.html file automatically. You have a
choice of whether to not create this file (Omit), create a page which is a symbolic
link to the Table of Contents page (Link), or create a page which is an exact Copy of
the Table of Contents page. By default, the link option is preferred because if you
alter the Table of Contents page, the symbolic link always reflects the latest version.
However, on some web servers (including iDisk), links are not possible, so in this
case, you should choose either Omit or Copy. 

If you choose to Omit an index.html and you leave the “index” default setting for your
Home Page URL, PhotoToWeb will make the Home button on your navigation bars
point to the Table of Contents page. If you want to make your own index.html page
and you want the Home button to point to it, set the Home Page URL to
“./index.html”. 
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Preferences - Misc - Slide Display

To view slides on a second monitor if you have two monitors connected, check
the Display Slides on second monitor checkbox.

To set other Slide preferences, choose Views -> Slide Show Settings, make
the settings you want to apply to future albums, and click the Set for All New Docs
button.
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Web Output - Creating Web Pages
Once you’ve prepared your images and set your web options you can make your
web pages.

To create web pages to display your album:

1. Choose Web -> Create Web Pages... .

2. Choose a location for your new folder of .html and image files and type in the new
folder’s name in the Save dialog.

PhotoToWeb generates HTML pages and the reduced-size image files that you’ve
specified by setting the size, cropping, copyright info, and image quality.

By default, PhotoToWeb creates a two level folder hierarchy: the web pages are
placed in the folder that you name in the standard Save dialog, and the images are
placed in a subfolder named “images”:

Saved Folder Name

images
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Web Output - Creating Web Pages

3. Select your output options.

To put all the images and annotations on one
web page, click the All on one page radio button.

To give each image and its annotations a
separate page, click the Each photo separate
radio button.

To output just the current image and
annotations (useful if you are updating pages),
click the This photo only radio button.

To output just the HTML without generating the
image files (useful if  you’ve changed the text
without changing the image settings), check the No
Photos - Just HTML checkbox.

4. Click the OK button. The HTML and images for
your web pages will be generated and your web
browser will be asked to open the Table of
Contents (or first page, if there is no Table of
Contents page). At this point, you can look at the
results. If you want to change something, it's easy
to go back to PhotoToWeb, tweak some settings,
and generate the web pages again.

Dancing, drumming, juggling and stiltwalking open the big BIG Show!

The Opening Act

Welcome to PhotoToWeb, which lets you review images
, rename them, reorder them, remove bad ones, annotate them 

and instantly build a web site! Choose 

 (such as 
from digital cameras)

Photos->Create Web Pages... 

With great grace and balance these artists nary spill a drop...

The Water Dancers

With Output Scale & Rotation, you control whether you want to use the original 
photo (100%), or a smaller one which will be smaller in file size for faster downloading 
over the web. You can also scale all of your photos to a given width with Photos->
Web Scale... You can set the size of thumbnails and many other web output options, 
including whether the original large scale photos are included in the web site.

The kids are singing and signing (ASL) 'You Can Get It If You Really Want'

The Grand Finale

For more info on using PhotoToWeb, choose Help or visit
www.stone.com. 
These photos copyright 1999 Andrew C. Stone, All rights reserved.

Created with  at 2001-12-09 11:20:19 -0700Stone Design's PhotoToWeb®
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Web Output - Modifying Existing Web Pages

To overwrite an existing folder hierarchy, choose Web -> Create Web Pages…
and navigate to the folder you want to overwrite. Select any .html file in that folder
and click OK. You’ll get a warning panel asking if you really want to replace that file.
If you click OK, the newly generated files will replace old files with the same name.

If you’ve only modified the annotations on your images and haven’t changed any
of the image options, overwrite the existing hierarchy as described above and check
the No Photos - Just HTML checkbox. The image files will not be replaced. This can
save a lot of time; the image files take longer to generate than the HTML pages.

If you’ve only modified one image and/or the annotations on one image, choose to
overwrite the existing hierarchy as described above, and click the This photo only
radio button. Only the HTML and image files for the currently selected image will be
generated. If you click the This photo only radio button and check the No Photos -
Just HTML checkbox, only the HTML for the current  image will be generated.
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To generate thumbnail image files without generating a complete web site:

1. Choose Web -> Make Thumbnails.

2. Type in the name of a new folder and click OK. PhotoToWeb will generate one
HTML file to display the thumbnail images (TOC.html) and an image subfolder
containing the thumbnail image files.

Your web browser will be asked to open the Table of Contents file.

The thumbnail image size and quality is set in the Web Options window.

Web Output - Generating Thumbnail Images
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Library Trees - Multilevel Web Sites
With Library Trees, you can automatically create linked, hierarchical web
sites from nested folders and subfolders of photos.
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Library Trees (page 2)

To make a new library tree, choose File -> New Library Tree.

A Library Tree is a collection of albums. As a convenience, you can add folders of
photos to a Library Tree; PhotoToWeb will automatically create an album in the
folder if it doesn’t already contain one.

To add albums and folders of photos to a Library Tree, drag them from a Finder
window or click the Add button and use the Open dialog to navigate to the album or
folder you want to add.

If you add a folder that includes other
nested folders of albums, PhotoToWeb
will duplicate the file structure in the
Library Tree by automatically creating a
node (a folder that contains albums) for
each folder that contains other folders.

A node can contain albums and other
nodes.

To create a new node, select the node
that you want to contain the new node
and click the New Folder button.
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To add albums to a node, drag and drop the album. You can move albums that are
already in the Library Tree or you can add albums from the Finder.

Here, we’re moving the Men’s Chorus
album to the Friends node.

To remove albums or nodes from
the Library Tree, select the album or
node and click the Remove button.

To open an album for editing, select
the album and click the Open Album
button.

Library Trees (page 3)
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Library Trees - Options

To display the
Options drawer,
click the round
button.

To change the
name of the
album, edit the
Album Title text
field. The Album
Title is used on
the Table of
Contents pages
and as the title
prefix within the
album.

To change the
name of
subfolder that
PhotoToWeb will
create when it
generates the
HTML and
images, edit the
Subfolder Name
text field.
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Library Trees - Web Options

PhotoToWeb generates
a Table of Contents
page for each node in
the Library Tree. To set
the appearance of
these TOC pages, use
Web -> Web
Options…. You can set
the navigation bar style,
the thumbnail size,  the
text, link and
background colors, and
any additional HTML.

To apply these
options to all the
albums in the Library
Tree, check the Apply
top level HTML options
checkbox in the Options
drawer. This overrides
all the web option settings for the individual albums, and gives the site a uniform
look.

To apply a saved album style to a Library Tree, open the Album Styles window
(File->New From Styles…), select an album style, and drag its icon from the image
well to the Library Tree.
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Library Trees - Generating HTML

To generate the HTML for a Library Tree, choose Web -> Create Web
Pages…. You have the same controls as you have with individual albums:
you can choose to put all the images in an album on the same page or make
a separate page for each image. You can also choose to generate only the
HTML without generating the image files (useful if you’ve changed the
appearance of the Library Tree without changing the structure or any of the
images).

PhotoToWeb creates a main folder that contains TOC.html, index.html, an
images folder and folders for the top level albums and nodes. Each node
folder duplicates the structure of the top level folder. Each album folder
contains TOC.html, index.html, an images folder, and HTML files for each
page in the album.
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Slide Shows
To view the images in your album or Library Tree in a full-screen slide show, choose
Views -> Slide Show.

To change the slide show settings for your album or Library Tree, choose Views ->
Slide Show Settings to bring up this window.
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Slide Shows: Settings and Controls

Settings:

To set the amount of time the image remains on the screen, select a Delay
amount.

To set the slide transition style, click one of the Transition radio buttons.

To set the relative frames per second, use the Speed slider.

To apply these settings to all subsequently created albums and Library Trees,
click the Set For All New Docs button.

Control:

To start the slide show, choose Views -> Slide Show.

To stop the slide show,  double-click or press the Space, Delete, or Escape keys.

To manually control the slide show, click the mouse button once to enter manual
mode. Then use the Arrow keys to move through the images. Click the mouse
button again to reenter automatic mode.

To go as quickly as possible through the images, hold the Shift key.
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Installation
1. Unpacking if you downloaded

If you download PhotoToWeb from http://www.stone.com/NewDownload.html, you
will have a file like:

PhotoToWeb-2001-01-01.dmg

Double-click that file to produce a mounted disk image. 

2. Installing (this is step 1 if you have a Stone Studio CD!)

Drag the PhotoToWeb application from the mounted disk image or CD to your
/Applications folder (click the Applications button in the Finder to reveal
/Applications). You can put PhotoToWeb anywhere on  your computer's disks, but
/Applications or your home folder's Applications folder is the best place to put
applications.

3. Licensing

When you first launch PhotoToWeb, a license panel comes up; you can run
PhotoToWeb in Demo mode or choose to register it at that time. You can always
select PhotoToWeb -> License... to bring up the license panel. If you don't have a
license string, contact Stone Design or visit our online store.
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Ordering Licenses

To order PhotoToWeb, visit the secure Stone Store server by choosing
PhotoToWeb -> Purchase….

You can fax us PO's at: (USA) 505-345-3424

You can send cheques and money orders to:
Ê Ê Ê Ê Stone Design Corp
Ê Ê Ê Ê 2400 Rio Grande Blvd NW pmb 116
Ê Ê Ê Ê Albuquerque, NM 87104
Ê Ê Ê Ê USA

You can give us a call at (USA) 505-345-4800

You can email us at orders@stone.com

Support

If you have searched Help and cannot find your answer, contact Stone
Design via info@stone.com for fast email support. The easiest way to do
this is simply choose Help -> Suggestion Box... which will take you to our
online feedback center.

Technical Support



76 PhotoToWeb Manual

Installation

Unpacking
Licensing
Tech Support
Legal

Quick Start
Image Prep
Web Options
Album Styles
Preferences
Web Output
Library Trees
Slide Shows
Installation
Technical

2
8

30
51
55
62
66
72
74
77

Disclaimer:
Stone Design disclaims all warranties with regard to this software and
technology to the extent possible by federal law, including all implied
warranties of merchantability and fitness, in no event shall Stone
Design be liable for any special, indirect or consequential damages or
any damages whatsoever resulting from loss of use, data or profits,
whether in an action of contract, negligence or other tortious action,
arising out of or in connection with the use or performance of this
software. 

Legal
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Technical Information
Album Structure
Applescript
CSS
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Album Structure

Albums do not store your images. Instead they store the path to your image.
That is, if your user name is kris and your images are in a folder named Photos
in your Documents folder, an album would store a path like
“/Users/kris/Documents/Photos/somephotoname.jpg”. By not storing the
images within an album, albums are kept very small. However, not storing the
images themselves can cause issues if you move or rename the images.

For example, suppose you decide to get organized, so you make some
subfolders and move your images. In the process, you move
“somephotoname.jpg” to a subfolder of “Photos” called “Misc”. Now the path to
the image is “/Users/kris/Documents/Photos/Misc/somephotoname.jpg”, but
your original album thinks the path is still
“/Users/kris/Documents/Photos/somephotoname.jpg”. When you open the
album, PhotoToWeb will ask you to locate the missing image:
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If you choose Ignore, PhotoToWeb will not modify the image information in the
album. The image will not be viewable; PhotoToWeb will display a generic image in
its place. The next time you open the album, PhotoToWeb will give you another
chance to find the image (unless you moved it back to its original location).

If you choose Remove Photo, the image will be removed from the album.

If you choose Find Photo, an Open File dialog will appear so you can navigate to the
new location. PhotoToWeb will store the new path in the album (remember to Save
the album).

Album Structure (page 2)
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To avoid issues with moving images, save your album in the same folder with
the  photos that are included in the album. You can move the folder safely
because PhotoToWeb will look in the album’s folder for the photos.

If you’re going to use the photos in multiple albums, change the photo
filenames in the first album that you make with the photos. In other albums,
just change the Title field and leave the photo names the same. This ensures
that the first album will be able to locate the photos.

Album Structure (page 3)
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Applescript

PhotoToWeb is scriptable. If you know how to write Applescripts, you can use the
Script Editor to examine PhotoToWeb’s dictionary.

Even if you’re not a scripting expert, you can use Applescripts to automatically
create albums and web sites when you download photos from your digital camera.
You can also automatically display your photos in a slide show. PhotoToWeb
includes sample Applescripts to generate web pages, run a slide show, and
generate thumbnails.

To use the sample Applescripts, copy them from the Image Capture subfolder of
the Scripts folder in the PhotoToWeb disk image to your hard disk. You can put
them anywhere, but standard places for scripts are
“Users/yourname/Library/Scripts” and “/Library/Scripts” (accessible by anybody
using your computer). Also, a standard place for Image Capture scripts is
“/Library/ImageCapture/Scripts”.
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Applescript (page 2)

To automatically create web pages:

1. Plug in your digital camera or USB Smart Media or Compact Flash card reader. In
OS X, when you plug in a compatible USB device, the Image Capture application will
automatically launch.

3. Using the Automatic Task dropdown menu, choose Other and then in the Open
dialog, navigate to the “PhotoToWeb-web pages” script. You’ll only need to do this
once; Image Capture remembers the scripts you select.

4. Click the Download All button.
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Your photos will be downloaded and PhotoToWeb will open, put all the images in an
album, generate the HTML web pages based on your Preference settings, and ask
your favorite browser to open to display the newly-created site.

Here is the script:

To edit this script, open it in Script Editor. For example, you might want to
change the location of the saved folders by changing the definition of basedir
in the script. Be sure to save it in Script Editor as an Application so it can
accept a selection. 

Applescript (page 3)
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You can also drag and drop a group of
photos or a folder containing photos onto
the script in the Finder, and PhotoToWeb
will automatically create an album and
generate the HTML for the album.

Remember, the settings are based on your
Preference settings; if you want to change
the look of your automatically-generated
sites, change the settings in Preferences.

We’ve also included scripts for generating
a collection of thumbnails and
automatically starting a slide show from
your downloaded images.

Applescript (page 4)

We’ve included one additional script that starts with a Create® document. This
script makes jpeg images out of each page in the currently active Create
document, puts them in a PhotoToWeb album, and starts a slide show.

Check our web site for additional scripts as we develop more ways to get the most
out of PhotoToWeb.
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CSS
PhotoToWeb provides a great deal of control in setting your pages’ appearance.
However, it can’t provide the flexibility that you can achieve by handcoding HTML.
PhotoToWeb has taken a step in that direction by surrounding various elements in
the HTML it generates with class names. These class names can be used in CSS
(Cascading Style Sheet) styles to control the pages’ appearance.

For example, by putting the following specification into the header HTML and
choosing to use text navigation bars,  you can give your menu a rollover effect:

<STYLE TYPE=”text/css”>
.menu {background-color: #FF00FF; }
.menu a:link {color: #0000FF; font-weight: bold; text-decoration: none; }
.menu a:visited {color: #894F7B; font-weight: bold; text-decoration:
none;}
.menu a:active {color: red; }
.menu a:hover {text-decoration: underline; background-color: #FFFFFF; } 
</STYLE>

Note: hover is not supported by all browsers.
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CSS - Table of Contents

The title is in a <div
class=”toctitle”>

Each thumbnail image is
in a table with
class=”thumbtable”.

Each image title is in a
<div class=”thumbtitle”>.

The PhotoToWeb credit
at the bottom is in a <div
class=”p2wcredit”>

Don’t judge these on aesthetics! Each class has a
different colored background.
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If the navigation bar is text only,
it’s in a <div class=”menu”>.

The Title, image, caption, and
story are enclosed in a table with
class=”maintable”.

The image is enclosed in a table
with class=”picturetable”.

The caption is in a <div
class=”caption”>.

The title is enclosed in <H2
class=”phototitle”>.

The story is enclosed in <div
class=”story”>.

The PhotoToWeb credit at the
bottom is in a <div
class=”p2wcredit”>.

 |  |  | Previous Home Index Next

Dancing, drumming, juggling and stiltwalking open the big BIG Show!

The Opening Act

Welcome to PhotoToWeb, which lets you review images
, rename them, reorder them, remove bad 

ones, annotate them and instantly build a web site! Choose 
(such as from digital cameras)

Photos->
Create Web Pages... 

 |  |  | Previous Home Index Next

Created with  at 2001-12-12 17:56:59 -0700Stone Design's PhotoToWeb®

CSS - Image Page
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The title is in a <div
class=”toctitle”>.

Each thumbnail image is in a
table with class=”thumbtable”.

Each image title is in a <div
class=”thumbtitle”>.

The whole site menu is in a
<div class=”sitetext”>.

The current location is in a <div
class=”currentsitetitle”>

The other items in the whole
site menu are in a <div
class=”sitetitle”>.

The PhotoToWeb credit at the
bottom is in a <div
class=”p2wcredit”>

: Table of Contents

Food Friends

    Food

        Chile Rellenos 2000

        Tamales 2000

    Friends

        A N

        Rae Perl's Open House 2000

        Dancers

            Half Crazies 12:00

            Senior Square Dancers 12:00

            WB Callers Night 12:00

Created with  at 2001-12-12 18:03:24 -0700Stone Design's PhotoToWeb®

CSS - Library Tree Table of Contents
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Users occasionally ask for a feature that we can easily do but that we don’t think is of
general enough interest to put into the user interface. So we put the feature in the
code and activate it with a hidden default.

To set a hidden default, open the Terminal application, and type:

defaults write com.stone.PhotoToWeb defaultname defaultvalue

where defaultname is replaced by the name of the default and defaultvalue is
replaced by the value of the default.

To remove a hidden default (in other words, to go back to PhotoToWeb’s standard
behavior), open the Terminal application and type:

defaults delete com.stone.PhotoToWeb defaultname

where defaultname is replaced by the name of the default.

Here are some available defaults:

To replace the words “Table of Contents” on the Table of Contents page, type:

defaults write com.stone.PhotoToWeb TOC “whatever you want”

where you replace “whatever you want” with your preferred name (including the
quotes).

Hidden Defaults
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To make PhotoToWeb link the Home navigation bar button to “index.html”
even if you tell PhotoToWeb not to create an index page, use:

defaults write com.stone.PhotoToWeb LinkHomeToMyIndex YES

Currently, PhotoToWeb assumes that if an image is small, you want to output it at
full size, even if a scale value has been set. To change what PhotoToWeb uses to
determine what small is, use:

defaults write com.stone.PhotoToWeb OutputFullSizeIfUnder 10

where you replace 10 with whatever you want your minimum size to be.

To not automatically launch the browser after you generate the HTML for an
album, use:

defaults write com.stone.PhotoToWeb kyle YES

By default, PhotoToWeb adds types and creator codes to the HTML and image
files it creates. To turn this off, use:

defaults write com.stone.PhotoToWeb UseMacTypes NO 

Hidden Defaults (page 2)


